User Tools

Site Tools


Introduction | Session 1 | Session 2 | Session 3 | Session 4 | Session 5 | Session 6 | Session 7 | Session 8


Session 7: Create a Help File

Estimated completion time → 15 minutes.

In this practical session, you will create a help file for your EASAP. This will be accomplished by using Microsoft Word to produce the help file content and then to write this file out as HTML. Please follow the instructions below to complete this practical session.

Note: This practical session is designed for computers running under Windows with Microsoft Word installed. For other computer types, you can use the word processor or HTML editor of your choice and use the following instructions as a general guide.

  • Start up Microsoft Word on your computer
  • Open the file Helpfile.doc supplied with the rest of the tutorial files.

The document should look like this:

First you will create hyperlinks from your Help File Contents section down to the relevant sections lower in the file.

  • Highlight the bullet item ‘Overview’ with your mouse, and then click on the Insert menu and select Hyperlink (or type Ctrl-K)

A pop-up window will appear which will depend on your version of MS Word

  • Select the Place in This Document button on the left side of the window
  • Expand the ‘Rectangular Plate Loading Analysis’ node on tree and then select ‘Overview’ on the tree. Click on OK.

The ‘Overview’ bullet item should be now in blue underlined text and be a hyperlink

  • Repeat for the other two bullets: ‘How to Use EASAP’ and ‘Input Details’
  • Now replace the Author’s contact information of Name, Phone number and E- mail address at the bottom of the ‘Overview’ section with your name, phone and e-mail
  • Save the file as an HTML called help.html (type: Web Page, filtered). This step varies based on your version of Word. Note that some versions of Word default to a file type of .htm and you may need to define .html explicitly (using DOS command prompt: type 'copy help.htm help.html' then 'del help.htm ' to avoid confusion with the file name extension.)
  • Exit Word by selecting File→Exit.
  • Start EASA log in and Set Mode→Author.
  • Under EASA→Applications→My EASAPs select ‘Rectangular Plate’ EASAP.
  • Under EASA→Authoring→Files click on the Browse button to the right of the File to upload: input box.
  • In the Look in: box on the pop-up window, select the folder on your computer in which you just saved the help.html file.
  • Then select the file and click on the Open button.
  • Finally, click on the Upload button in your EASA browser window.
    • → The help.html file will be added to your Current Files table

Now you can have a look at your newly formed help file as a user would do.

  • Under EASA→Authoring
    • Select EASAP Builder
      • Click on the Builder link on the new page.
  • After the EASAP window appears,
    • Select EASAP Help under the Help menu.

The help file content will appear in a new browser window like:

  • Exit the help file browser and then exit the Builder.

We have completed Session 7. Let's continue with Session 8.


Introduction | Session 1 | Session 2 | Session 3 | Session 4 | Session 5 | Session 6 | Session 7 | Session 8


Page Tools