User Tools

Site Tools


EASAP Builder Interface

The EASAP Builder is the Interactive Development Environment (IDE) for creating an EASAP.


EASAP Builder Menus

The EASAP Builder has the following six top level menus.

File Menu

  • File > Save (or CTRL-s )
    Save the current version of the EASAP
    If the EASAP contains errors, a prompt to 'Save with errors' appears
    An EASAP that has been 'Saved with errors' cannot be published until the errors are fixed
  • File > Quick Save
    Save the current version of the EASAP while forcing 'Save with errors' behavior, above
    This option saves time but errors need to be fixed before the EASAP is published
  • File > Exit (or CTRL-q )
    Close the EASAP Builder
    A warning appears if there are unsaved changes in the EASAP
  • File > Save Local Copy
    Obsolete feature
    Instead use 'right-click > Export' and 'right-click > Import'

Edit Menu

  • Edit > Undo (or CTRL-z )
    Undo the last change that took place in the EASAP Builder
  • Edit > Next (or ALT-right-arrow )
    Step forward within the history of selected objects
  • Edit > Previous (or ALT-left-arrow )
    Step backward within the history of selected object
  • Edit > Redo (or CTRL-y )
    Perform the most recent action again
  • Edit > Find (or CTRL-f )
    Open a dialog where the current EASAP can be searched with various conditions.
  • Edit > Find Next (or F3 )
    Find the next occurrence of the conditions last entered

Tools Menu

  • Tools > Submission > Estimate Number of Runs
    Based on Parametric Studies values
  • Tools > Reset All
  • Tools > Security
    Configure EASA Client network security settings
  • Tools > New Application Wizard
    Create a new EASAP by launching the wizard
  • Tools > Write SQL Wizard
    Launch the SQL wizard for INSERT, UPDATE, DELETE… actions

View Menu

  • View > Font (or CTRL-t )
    Adjust font, font face and size in the EASAP Builder
  • View > Console
    Show the log for the EASAP Builder

Application Menu

  • Application > Edit Template
    Open the Template Editor
    This option is only enabled when it’s valid.
  • Application > Test in Web Browser
    Open the EASAP with a Web Browser client
  • Application > Test in EASA Client
    Open the EASAP with an EASA Client (no longer supported)

Help Menu

  • Help > General Help
    Open the Author's Guide from the EASA Help Pages in a browser window
  • Help > EASAP Help (or CTRL-h )
    Open 'help.html' to assist an Author in a browser window
    A default 'help.html' is provide, an Author is encouraged to replace it
    A User may click the question mark icon in the upper right corner of a running EASAP GUI to open 'help.html'
  • Help > EASAP Information
    Show basic information about the EASAP
  • Help > About
    Show EASA version and trademark

EASAP Toolbar

The top toolbar is the EASAP toolbar.

Icon Name Function
SaveSave EASAP as current development version ( CTRL-s )
UndoCancel the most recent change made, applies multiple times ( CTRL-z )
RedoRestore the most recent canceled change, applies multiple times ( CTRL-y )
RefreshRefresh the object Tree view and all values
FindFind specified text in object names and parameter values ( CTRL-f )
PreviousNavigate back through previously selected Tree objects ( ALT-left-arrow )
NextNavigate forward in previously selected Tree objects ( ALT-right-arrow )

Even after using the ‘New EASAP’ or ‘Save as New EASAP’ functionality to produce a new and separate EASAP, the currently selected EASAP back on the EASA web pages will remain the same as when EASAP Builder was initiated.


Builder Toolbar

Just below the EASAP toolbar is the Builder toolbar.

With this toolbar an Author may:

  • Switch between Tree mode and Preview mode
  • Copy, Cut, Paste and Delete objects on the Tree,
  • Add comments to annotate objects on the Tree
  • Export and Import objects to and from your computer, and
  • For the selected object show which sibling or child objects are valid,
    Click 'Add Sibling objects' or 'Add Child objects' button
    Object icons are added to the toolbar which represent the current valid sibling or child objects
    Click on an object to add it to the Tree under the selected object as a sibling or child

Descriptions of the individual buttons on the EASAP Builder toolbar are provided in the table below.

Icon Name
Keyboard Shortcut
Function
Open Web Browser TestOpen a test EASAP in Web Browser mode
Same as: EASA > Authoring > Testing > Test EASAP
See Enable Test > Exit button for Firefox
Open Web Browser Debug Open the EASAP in Web Browser Debug, see Troubleshooting an EASAP
Same as: EASA > Authoring > Testing > Analyze EASAP
Delete
DELETE
Delete the selected object from the Tree
Cut
CTRL-x
Cut the selected object from the Tree
Copy
CTRL-c
Copy the selected object on the Tree
Paste (Sibling)
CTRL-b
Paste a previously Copied or Cut object as a sibling below the selected object on the Tree
Paste (Child)
CTRL-v
Paste a previously copied or cut object as a child below the selected object on the Tree
Add/Edit CommentOpen a text entry box for inserting a comment as a Tool tip: for an object
Open Template EditorOpen the Template Editor
Save Object to FileSave selected object to a local file
Import Object from FileImport a previously saved object from the local machine
The imported object must then be Pasted into place on the Tree
Add Sibling ObjectsList any objects that may be added as a sibling
Add Child ObjectsList any objects that may be added as a child

Right-click Menu

A right-mouse-click while over an object on the Tree will display a menu that provides all the same functionality as the EASAP Builder Toolbar.

Adding a sibling or child object is often easier with the right-click menu and there are more options than the toolbar.

An example of the right-click menu is shown below.

In addition to the toolbar functions described above there are three extra functions:


Disable or Enable an Object

  • Right-click > Disable
  • Right-click > Enable
  • Right-click > Enable All

An Author may temporarily disable and re-enable an object (and each child object) on the Tree.

A disabled object behaves as if it has been deleted however it may easily be re-enabled at a later time.

An Author may disable a partially configured object in order to work on another.

Enable All re-enables all disabled objects in an EASAP.


Find Usages

  • Right-click an object on the Tree
  • Select: Find Usages

The EASAP Builder will navigate to each object on the Tree that makes reference to the selected object.

'Find Usages' behaves with objects in a similarly to the way Find behaves with a string.

This feature may be useful for keeping track of where and how each object is used in an EASAP.


Change Object Type

It is possible to convert certain objects from one type into another type while retaining properties such as name and Tree position.

Additionally any Excel formatting will remain consistent after the change.

The following object conversions are available: